Trapshooters Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3,380 Posts
Discussion Starter · #1 ·
I have a win. 101 that started acting up today, looking for solutions from you 101 Gurus. If I fire bottom barrel or top barrel (singles) all works well. If I fire both barrels, as in doubles, it is hard to open the gun. If you fire both barrels without ammo in the barrels (dry fire) it works perfectly fine. I have taken the gun completely apart & thoroughly cleaned & degreased it. Still doing the same thing. OK, what the heck is wrong?
The only thing I can think of myself is replace the firing pins & springs. Not sure how to do that yet so would have to research that one. I know Brownell's had pins and springs several years back. I will take any & suggestions. Thanks, Colonel
 

·
Premium Member
Joined
·
2,344 Posts
Have you changed your loading at all? Same powder charge? Same hulls? Are your chambers clean and smooth? After releasing both firing pins you are cocking both hammers but that should not be an issue... One thing that is changing is after firing both barrels you are extracting two hulls..... check the diameter of the brass at the base.... perhaps you are not sizing quite enough. Numrich currently has both firing pins and springs for the old/made in Japan 101's. I purchased a couple last week....... Larry
 

·
Banned
Joined
·
495 Posts
Check and see if the firing pin is punching thru the primer. Or if it is worn and is just hanging up in the primer. Look at the empties and see if they have drag marks left by the firing pin. Roger C
 
1 - 5 of 5 Posts
Top