Trapshooters Forum banner
Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
253 Posts
Discussion Starter · #1 ·
O/T I have A 2003 Chevy S-10 pickup with 75K miles. The tranny just went out. It has had very light duty. Anyone else had A problem like this with theirs? I'm not A very happy camper about it.
Roy A.
 

·
Registered
Joined
·
253 Posts
Discussion Starter · #5 ·
Yes. it is A 4L60E Automatic transmission. The teeth on the reaction shell were all wore off. This is the 3rd S-10 I've had and all the others had well over 100K on them and I never had trouble with any of them. At least the rebuilt one has A 75K warranty on it.
 

·
Registered
Joined
·
115 Posts
yes i did i had a 02 s10 zr2 which is 4x4 and the only trans you can get with a 4x4 is an auto the trans went out at 24,000 miles and again at 38,000 miles same problem both times it was what they called a reverse rotate something i cant remember it lost both overdrive and reverse when it went out them idiots told me to drive it to a dealership 45 miles away i told them i wasnt going to drive 45 miles without overdrive unless the were going to guarantee me a new complete transmission they couldnt this was the only gm product ive owned and it my last also many other problems James Wilkerson

im curious to know did yours loose overdrive and reverse like mine ?
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Status
Not open for further replies.
Top