Trapshooters Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
So we were out shooting today and our Pat Trap started to windmill and then proceeded to grind up the bottom three targets in every stack. What a mess. Cleaned it all up reloaded it and it did it again. After it was cleaned it threw a couple of birds and then just started doing it again. HELP

Thanks for your thoughts
Jay
 

·
Registered
Joined
·
584 Posts
Sounds like a broken or loose no. 4 switch (located under the turret). You can look up the manual online if you don't have one.
 

·
Registered
Joined
·
3,280 Posts
You may have to adjust the cold weather switch a little to stop it from windmilling. I would try that first.

Is it a S series or a G series trap? Are you familiar with the location of the switch.

Ajax
 

·
Registered
Joined
·
4,069 Posts
Our brake broke off last shoot, still worked fine, surprised me. I thought the brake stopped the arm but must just help.

Breaking the bottom targets might be the arm mechanizim bound up. Operate it by hand and see, should slide easily.
 

·
Registered
Joined
·
98 Posts
unplug the pull cord from machine. then turn on and see what happens. If it stops windmilling then it is in the cord. Has happened to us several times when pull cord got a knick or a cut in it.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #13
Thank you for all the help. I have studied the manuel now but have not had a chance to spend a little time with the machine. I will check the #4 switch and the cold weather switch on the 1st and let you all know how it comes out.
 
1 - 15 of 15 Posts
Top