Trapshooters Forum banner

1 - 6 of 6 Posts

·
Premium Member
Joined
·
760 Posts
Discussion Starter · #1 · (Edited)
Hi!

Anyone ever see this?

On 20% or so of priming tries, hull hangs up and then "snaps" loudly over the primer. Eyeballing the loader, the shell plate is over-rotating a bit causing a misalignment of the primer and the primer hole in the hull.

See pix. Alignment on my 9000 (gas cylinder advance, bottom pict) is perfect but not on the 650 (rotation by hand, top two picts). Also, primer edge rub mark on the 650 is clearly off center.

Ideas?

jk
View attachment 317529
View attachment 317530
View attachment 317531
 

·
Registered
Joined
·
1,620 Posts
Hi!

Anyone ever see this?

On 20% or so of priming tries, hull hangs up and then "snaps" loudly over the primer. Eyeballing the loader, the shell plate is over-rotating a bit causing a misalignment of the primer and the primer hole in the hull.

See pix. Alignment on my 9000 (gas cylinder advance, bottom pict) looks perfect but not so much on this 650 (rotation by hand, top two picts). Also, primer edge rub mark on the 650 is clearly off center.

Ideas? your manual that came with the loader will tell you how to adjust the over travel of the plate.

jack mc

jk
View attachment 317529
View attachment 317530
View attachment 317531
 

·
Premium Member
Joined
·
760 Posts
Discussion Starter · #3 ·
It is the 650 plate that over rotates when turned by hand. The detents "stop it" mis-aligned with the deprime station.

jk
 

·
Premium Member
Joined
·
760 Posts
Discussion Starter · #4 ·
Guys,

Thanx but the problem is with the 650 - the 9000 is perfect!

No gas cylinder on the 650, the shell plate is rotated by hand.

jk
 

·
Registered
Joined
·
32,265 Posts
Oh, okay.

when it rotate the plate, "you feel a crisp index each time the ball drops into the indent"?

No play in the plate, ball missing? Index spring about 90 degrees from the index ball?
 

·
Premium Member
Joined
·
760 Posts
Discussion Starter · #6 ·
Update

Had a couple of great chats and exchange of pix with Gordie at MEC and the best analysis is that the rotation is OK but rather the red flat base plate is a bit askew leading to the mis-alignment.

Even though well out of warranty MEC is sending me a new bottom assembly which should do the trick!

Thanx for the PMs and replies and the great MEC responsiveness!

jk
 
1 - 6 of 6 Posts
Top