Trapshooters Forum banner

Mec Auto Mate- Trouble

2654 Views 9 Replies 7 Participants Last post by  SMITH47
I have been using my mec automate with a grabber for about a year with no problems. yesterday the flywheel attached to the electric motor decided to go in the opposite direction and the rod that goes from flywheel to reloader locked against the rear of the grabber. i have a backup grabber i will use till i get it fixed. I know the folks with mec will help me.. anyone have this happen or some suggestions ??

thanks,

ernie
I have been using my mec automate with a grabber for about a year with no problems. yesterday the flywheel attached to the electric motor decided to go in the opposite direction and the rod that goes from flywheel to reloader locked against the rear of the grabber. i have a backup grabber i will use till i get it fixed. I know the folks with mec will help me.. anyone have this happen or some suggestions ??

thanks,

ernie
See more
Status
Not open for further replies.
1 - 10 of 10 Posts

· Registered
Joined
·
143 Posts
I had the same problem, but in my case the little "c" clip that holds the wad guide vertical rod and centers the spent primer drop tube over the collett slipped off after 10 years of use. The missing "c" clip caused the wad guide rod to drop to the bottom and then all hells breaks loose. End result was a bent pusher rod just like above. Looks like the "c" clips should be replaced periodically as mine were worn and somewhat concave.

Ron
 

· Registered
Joined
·
307 Posts
Texas - the other evening that happened and I had pieces flying in every direction. Glad I had glasses on because a piece of a retaining clip bounced off my right lens (the "good" eye!). But here's what I don't get about this AutoMate, guys: I thought if it encountered any kind of obstruction or resistance, it was supposed to back off? That's when you usually get to change a fuse.

Doc
 
1 - 10 of 10 Posts
Status
Not open for further replies.
Top