Trapshooters Forum banner

Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
154 Posts
Discussion Starter · #1 ·
I have been using a MEC 9000H for about 7 years now. Just recently, it has started, on a random basis, not droping shot or droping it AFTER the shell has started to move to the next station. I am loading #6 shot for crow shooting.

I sent an email to MEC on Thursday, but have not received a reply yet. Has anyone experienced this, and what did you do to stop the problem?

Thanks.

John
 

·
Registered
Joined
·
72 Posts
It sounds to me like you need to clean the tubes and the funnels.
The tube anf funnel will gunk up on you after time.
Soke the tube in some hot water with Dawn, take a green pad and cut a strip and run it through the tube.
Both tubes will just lift out if you tilt the upper bottle section.
 

·
Registered
Joined
·
884 Posts
sounds like the shot is bridging in the tube,I had the same trouble with #6s filed and sanded the inside of tube that help,some have told me to cut the bottom off a little to open the lower hole up.(I did not)
 

·
Banned
Joined
·
5,706 Posts
Cut the Bottom off the shot dropping tube about 1/8th inch, or open it up with a round Rat Tail File then sand with sand paper in a split dowel rod that will fit the opening.


Gary Bryant
Dr.longshot
 

·
Registered
Joined
·
10,448 Posts
I routinely remove and polish the inside of the powder and shot drop tubes with steel wool on a drill rod on the Mec press. I don't remember the last time I had shot bridge. I have loaded shot as large as #5.
 

·
Registered
Joined
·
154 Posts
Discussion Starter · #9 ·
I am going to try to polish the tube first. The shot tube only comes in a kit, so if a little polish will save $4o, I think I will try it.

Thanks for the advice guys.

John
 

·
Registered
Joined
·
319 Posts
Make sure the shot bottle is not comming in contact with the charge Bar.
I was having this problem....Seems the plastic bottle threds were comming in contact with the bar as it moved from left to right...It would hang up momentaraly...creating a mess.
I had just ordered new bottles from MEC, I returned the bottle to MEC, They replaced my old one problem solved.
I think it was a bad batch of bottle & threds
 

·
Registered
Joined
·
9,941 Posts
Here's the problem I'm having.

The press (a 9000H) is all the way down and about ready to start back up.

The first quarter inch is fine . . . but then, every now and then

just as the wad guide lifts out of the mouth of the shell, there are still a few pellets _in_ the wad guide and a few of them spring out onto the rest of the press and you know what happens then, eventually.

The setup: One-ounce bar, small shot, either AA pink or Remington Green, a bit of wad pressure according to the indicator.

Any ideas?

Neil
 

·
Registered
Joined
·
10,782 Posts
Neil, more wad pressure to get the dropped charge lower when it begins its return stroke. Too many pellets remaining in the wad fingers cause this. Hap
 

·
Registered
Joined
·
572 Posts
Neil, are you loading Gold Medal hulls? If so the drop tube is pulling the wad back up to the wad fingers.

Just for grins, I would clean the outside of my drop tube and apply either, silicone spray or spray wax.

Hope this helps. GOOD LUCK
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top