Trapshooters Forum banner

KX6 ejector problem

1078 3
The last two times I shot my KX6, between 40 and 45 shots the ejector jumped over the the plunger that is supposed to keep it in place. I could not push the extractor back over the plunger until later, after completely disassembling the ejector everything went back into place and it worked until the next time I used the gun and the same thing happened. A guy told me that there is a steel ball under a plunger that gets out of time. I had disassemble this extractor to clean it after shooting in the rain but I was very careful and I never saw a steel ball. Now I took it apart again and there is no steel ball. Did I lose it the first time I took it apart or doesn't it exist? Has anyone had this problem?
1 - 4 of 4 Posts

· Registered
Joined
·
13,498 Posts
If the shotgun is less than 10 years old? It is still covered by the factory warranty. Any Krieghoff dealer should fix this problem for nothing. You should be talking to them and not to us!!! Krieghoff is the only place who will have the ball, if you need it. It may also be a good idea to have a K-gun factory trained gunsmith look at your ejector as well. As it might be worn or bent? Good Luck to Ya. break em all jeff
 

· Premium Member
Joined
·
6,031 Posts
Not sure about the KX6, but the K-80s have a detent ball and spring. So my guess is, yes you lost the ball. They are not very big and are easy to lose if they roll off of the table. Don't ask me how I know.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top