Trapshooters Forum banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I've had my 391 for 7 years now and for the last four years I've had an issue with cycling for doubles as I've mostly shot trap and just started shooting skeet.

The second shell will cycle up fine but when the bolt is moving forward the outside of the shell will catch on the front of the breach or back of the barrel. All I have to do is pull the bolt back slightly and release and it loads in fine. Sometimes if I just drop the first shell into the gun and close the bolt it will catch too.

Last year I had someone look at it and he replaced some parts to help (Can't remember them off the top of my head.) with cycling and he also cleaned it far better than I had been doing. This helped eject the first shell better but it would still catch.

Two others suggestions I've been given are to file down the edge of the barrel so it won't catch and to buy Winchester AA/Remington Nitro ammo because they are smoother shells. I don't want to file on the barrel and I don't want to pay $8 a box so any other suggestions or recommendations would be greatly appreciated. Thanks.
 

·
Registered
Joined
·
5,691 Posts
Look on this forum and Shotgunworld.com/I love my Beretta for the hundreds of threads about this. The most likely problem is that you have a twisted shell carrier. This occurs with most of the straight carriers that come in the 391.
Most of us solved the problem by replacing that carrier with the one that has a bend at the front end, and was used in the 303 and 390 triggers.
Sometimes the problem doesn't show up for years. I had my 391 for two years before it happened. Like many, I replaced the carrier and it has worked like a charm ever since.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
No reloads, just factory loads. I have found some threads more recently and they all mention the bent carrier so I think I'll try that first. Thanks for your help.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Been a long time but I finally switched the carrier to the bent carrier. All signs are good. So far more than 1500 rounds through with two stoppages. Both were during doubles trap. Same issue, second shell got caught. During 300 doubles though I've only had those two (knock on wood) problems. I believe both had something to do with a possible error I made or an odd motion. Hopefully it all remains good.
 

·
Registered
Joined
·
258 Posts
It's definitely the elevator. I sent my gun back to Beretta, as did a friend of mine. We both bought the Teknys Gold Sporting models about the same time, and we both were experiencing the same jamming problem. Beretta replaced the elevator with a different style on both as a retro-fit to solve the problem you are mentioning. I'm sure Tron will say the same thing. Since the elevators have been replaced on my friend's and my guns, they have worked flawlessly for well over 10K rounds. Beretta knows about this problem, so you should be able to send it to them to fix. Or, if you don't want to wait that long, call up Cole's in Maine and have them sent you the right parts. They'll know about the problem as well.
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top