1. Attention: We have put together a thread with tips and a tutorial video to help with using the new software. Please take a moment to check out the thread here: Trapshooters.com Tutorial & Help Video.
    Dismiss Notice

v-10 triton OIL PUMP R&R 99 f-350 SD 2WD

Discussion in 'Off Topic Threads' started by mx2005, Nov 6, 2009.

Thread Status:
Not open for further replies.
  1. mx2005

    mx2005 TS Member

    Joined:
    Feb 15, 2008
    Messages:
    430
    Any Ford mechanics could help I have a Lite rattle when firing up my 99 v-10 is it a big job to replace the oil pump and pick-up I did it in a 3500 GMC 454 before not a problem any help would be fine. Pat
     
  2. CalvinMD

    CalvinMD Well-Known Member

    Joined:
    Jan 29, 1998
    Messages:
    9,854
    Location:
    Northeastern MD @ the top o the Bay
    I think you might be barking up the wrong tree...are you using cheap filters with cheap backflow check valves
     
  3. TOOLMAKER 251

    TOOLMAKER 251 Active Member

    Joined:
    Jan 29, 1998
    Messages:
    3,398
    What makes you think changing oil pumps will make the "lite rattle" go away?
     
  4. emm2

    emm2 Member

    Joined:
    Jan 27, 2007
    Messages:
    318
    Yes it is a big job as this engine is a modular design and the oil pump is in front of the engine and not under the oil pan like the older style engine. Not something you are going to want to tackle without the cam holding tools as the timing chains have to come off and there are no alignment marks on the timing components. That said the rattle is NOT caused by a bad oil pump, most likely piston pin slap or bearing movement. This is very common on all modular ford engines. If the noise goes away after a few seconds and only happens after it sits for a long period of time then i would do nothing about it. Synthetic oil helps some as it leaves a slicker residue on engine components.
     
  5. KRK32

    KRK32 Member

    Joined:
    Feb 19, 2009
    Messages:
    274
    Location:
    TROY OHIO
    Check that your motor is a roller lifter setup before changing to full synthetic your may have to use the blended oil if it isnt. I had a friend that built up a motor in his mustang with flat tappet lifters and used full synthetic thinking it would be the best for the motor it gaulded the cam journals we did some research and found that synthetic oils are too slippery for flat tappet lifters in that it gets wiped away as the journal touches the lifter. I would also look at going to a heavier weight oil or try some of the lucas oil additive and see if you get good results. Kirk
     
  6. cubancigar2000

    cubancigar2000 Well-Known Member

    Joined:
    Jan 29, 1998
    Messages:
    10,521
    Location:
    Idaho
    PM Tron - he is a former Ford tech. I can tell you from my experience. I had it on a 2002 V10 and also on my 1998 5.4 Triton. When I start it it has a slight noise but goes away in seconds. It is worse in cold weather, I use synthetic Mobil 1 and it helps. Ford Tech told me to drive it and forget it. That was 40,000 miles ago, still purrs
     
  7. Bruce Specht

    Bruce Specht Well-Known Member

    Joined:
    Jan 29, 1998
    Messages:
    5,057
    Location:
    Near but not in chicago
    You may have a problem other thatn the pick up and pump. Some fords have probelsm with chain slap on start up. Find the source of the noise first
     
  8. mx2005

    mx2005 TS Member

    Joined:
    Feb 15, 2008
    Messages:
    430
    O.K. Thank you guys so much I WAS a GM TRUCK guy all my life until I Bought my
    first F-150 Super Crew in 03 I have been with Ford ever since and have 98 Expedition and still love it I didn't know that the pump was behind the cam chain and did know that the special tool is needed for the chain. I thank every one for their response and I know my 5.4 had a noise at first start up also, and they said it might be the cam chain tensioner. It does not last that long it is brief. Thank All you Ford mechanics and guys again I will keep the oil changed and I use a WIX filter I found they are still made the best and use 5-30w Motorcraft oil. Premium blend Pat.k.
     
  9. birddog1964

    birddog1964 TS Member

    Joined:
    May 3, 2009
    Messages:
    466
    Open hood take radiator cap off and drive a new bowtie under it and reinstall cap, that will take care of your problem.lol

    Lee
     
  10. Remstar311

    Remstar311 Member

    Joined:
    Sep 15, 2008
    Messages:
    942
    Out of all the oil filters I've taken apart I believe it was STP that had the most element.
     
Thread Status:
Not open for further replies.
Search tags for this page
forum v10 oil pump
,
priming oil pump for a ford v10
,

replacing oil pump on v10

,
replacing the oil pump on 99 f 350 v 10
,
testing an oil pump v10 triton
,
triton lite oil pump
,
v10 triton oil pump test
,
what does the oil pump on a triton v10 look like