1. Attention: We have put together a thread with tips and a tutorial video to help with using the new software. Please take a moment to check out the thread here: Trapshooters.com Tutorial & Help Video.
    Dismiss Notice

Shot Problem--Mec 9000H

Discussion in 'Off Topic Threads' started by chuckie68, Mar 22, 2013.

Thread Status:
Not open for further replies.
  1. chuckie68

    chuckie68 Active Member

    Joined:
    Jan 13, 2012
    Messages:
    1,839
    Location:
    Royal Oak, Michigan
    Just got my 9000 working today. Proceeded to try to load 100 STS hulls with 17.3gr. Red Dot a Claybuster CB1000 wad and #9's. I am using the large shot bottle. About 1/2 - 3/4 of the way thru the project, the machine started to drop light shot charges. By that I mean about half an ounce. Not every time but I lost about 10 or 12 hulls to the issue. It was a brand new bag of shot and the drop tube was clear on inspection. Anyone have this problem before? Does anyone have a clue as to why the press would do this?
    Thanks

    Chuck
     
  2. Ajax

    Ajax Well-Known Member

    Joined:
    Jan 29, 1998
    Messages:
    2,446
    Hi Chuck,

    Check to see if a thread off the shot bag is hung up in the bar. Make sure the bar is going all the way to the stop. There is an adjustment nut on the end of the rod that actuates the bar. If this is the reason your powder is not right either.

    Ajax
     
  3. chuckie68

    chuckie68 Active Member

    Joined:
    Jan 13, 2012
    Messages:
    1,839
    Location:
    Royal Oak, Michigan
    Thanks, I'll try both suggestions and report the results tomorrow
     
  4. chuckie68

    chuckie68 Active Member

    Joined:
    Jan 13, 2012
    Messages:
    1,839
    Location:
    Royal Oak, Michigan
    OK, I took the press apart tonight, I have bottle supports on it so all that had to come off. I changed all the seals, copper and rubber. When I reassembled the press to try it out, Ajax was correct. The charge bar was not going all the way to the left and the drop holes were partially blocked. I adjusted that, it only took 1 turn on the adjustment nut. Now the press seems to be working properly. I'll finds out for sure tomorrow as I am planning on loading a thousand shell or so. Thanks for the advice.

    Chuck
     
  5. StansCustoms

    StansCustoms Well-Known Member

    Joined:
    Oct 7, 2011
    Messages:
    1,466
    I decided to double nut the adjustment rod...since I've had them that would back off after a little while, with only one supplied lock nut.

    That ended the changes in the bar travel for me. Which by the way is the cause of most inconsistent shot and powder drops it seems to me.

    ..other than occasional drop tube bridges and or debris blockage.

    Stan...
     
  6. chuckie68

    chuckie68 Active Member

    Joined:
    Jan 13, 2012
    Messages:
    1,839
    Location:
    Royal Oak, Michigan
    I did all that and it worked ok for a while and started doing it again. I lost about 6 or 8 shells out of the first 100. I think I might be letting up on the foot pedal too fast?
     
  7. Strait Shooter

    Strait Shooter Member

    Joined:
    Jan 29, 1998
    Messages:
    70
    Make sure that either bottle is not screwed down too tight. If either one is too tight it will limit the travel of the bar.
     
Thread Status:
Not open for further replies.