1. Attention: We have put together a thread with tips and a tutorial video to help with using the new software. Please take a moment to check out the thread here: Trapshooters.com Tutorial & Help Video.
    Dismiss Notice

S-10 transmission

Discussion in 'Uncategorized Threads' started by ramen39, Nov 27, 2008.

Thread Status:
Not open for further replies.
  1. ramen39

    ramen39 Member

    Joined:
    Jan 29, 1998
    Messages:
    253
    O/T I have A 2003 Chevy S-10 pickup with 75K miles. The tranny just went out. It has had very light duty. Anyone else had A problem like this with theirs? I'm not A very happy camper about it.
    Roy A.
     
  2. BL350

    BL350 TS Member

    Joined:
    Jan 29, 1998
    Messages:
    244
    Dear R39,
    I am guessing this is a 4L60E automatic? Let us know please! Need a little more info!!
    Jet boat Bill
    Happy Thanksgiving anyway!!
     
  3. ec90t

    ec90t Guest

    Roy,

    How many times has the tranny been serviced? This can effect the life of a trans greatly.

    ec90t
     
  4. 320090T

    320090T Well-Known Member

    Joined:
    Jan 29, 1998
    Messages:
    3,351
    Location:
    Indiana
    Manual or auto?
     
  5. ramen39

    ramen39 Member

    Joined:
    Jan 29, 1998
    Messages:
    253
    Yes. it is A 4L60E Automatic transmission. The teeth on the reaction shell were all wore off. This is the 3rd S-10 I've had and all the others had well over 100K on them and I never had trouble with any of them. At least the rebuilt one has A 75K warranty on it.
     
  6. SARGE75X

    SARGE75X Member

    Joined:
    Apr 10, 2008
    Messages:
    648
    My sons 02 dumped at 95K, sun gear I think it was called, all the planetary gears revolve around it. Its been awhile, last Auto Trans I took apart was back in the 70's, a Turbo 350
     
  7. james25889

    james25889 Member

    Joined:
    Aug 3, 2008
    Messages:
    115
    yes i did i had a 02 s10 zr2 which is 4x4 and the only trans you can get with a 4x4 is an auto the trans went out at 24,000 miles and again at 38,000 miles same problem both times it was what they called a reverse rotate something i cant remember it lost both overdrive and reverse when it went out them idiots told me to drive it to a dealership 45 miles away i told them i wasnt going to drive 45 miles without overdrive unless the were going to guarantee me a new complete transmission they couldnt this was the only gm product ive owned and it my last also many other problems James Wilkerson

    im curious to know did yours loose overdrive and reverse like mine ?
     
Thread Status:
Not open for further replies.