1. Attention: We have put together a thread with tips and a tutorial video to help with using the new software. Please take a moment to check out the thread here: Trapshooters.com Tutorial & Help Video.
    Dismiss Notice

PW 800 plus question

Discussion in 'Shooting Related Threads' started by shot410ga, Jul 18, 2011.

Thread Status:
Not open for further replies.
  1. shot410ga

    shot410ga Well-Known Member

    Joined:
    Jan 29, 1998
    Messages:
    7,755
    I was loading on my 800+ with electric drive today. Everything is going smoothly for about 350 rounds. Then I hear a clump/bang/clump. I cleared all the shells, and looked for a problem. The only thing I found is that the shell plate goes backward now. That is to say, when I pull the handle (I disconnected the electric) the shell plate goes backward then goes forward, no longer indexing. Just back and forth. Any suggestions as to where to look or what do to correct the problem?
     
  2. STOS

    STOS Member

    Joined:
    Oct 8, 2008
    Messages:
    247
    Location:
    North Idaho
    Chances are your index pad is stuck down.Call me at 208 687 2231 to discuss.

    Bruce at P/W
     
  3. TjayE

    TjayE Member

    Joined:
    Jan 29, 1998
    Messages:
    704
    How can you get any better service than shot410ga is getting, right from the P/W factory. They do care about their customers. Thank you Bruce for your concerns / help.
     
  4. shot410ga

    shot410ga Well-Known Member

    Joined:
    Jan 29, 1998
    Messages:
    7,755
    Bruce, that was the problem. I cleaned and lubed the index pad device, and the loader works perfectly. Thanks.
     
Thread Status:
Not open for further replies.