1. Attention: We have put together a thread with tips and a tutorial video to help with using the new software. Please take a moment to check out the thread here: Trapshooters.com Tutorial & Help Video.
    Dismiss Notice

problems with pfs on mx2000???

Discussion in 'Uncategorized Threads' started by puablo, Mar 18, 2007.

Thread Status:
Not open for further replies.
  1. puablo

    puablo Well-Known Member

    Joined:
    Sep 18, 2006
    Messages:
    2,350
    i have a relatively new mx2000 that i put a precision stock on about 3 months
    ago. gun worked fine at first , but noticed during the winter while shooting
    rio ammo mostly that 2 to 3 shots out of 25 gave me problems...action seemed to open sluggishly. Also once in a while the gun would fire and gave the sensation of as you pulled the trigger, gun would go off and you would pull through the trigger further than usual, and action would open sluggishly after that too.

    i changed firing pin, leaf springs...still did it. i took trigger assy. out of mx10 that i have and put it in to see if it was the triggers, it did it much less, but still did it once or twice out of 175 rounds. im thinking maybe the stock has to be fitted to the receiver better. i'm going to take the pfs off and put the wood stock back on to see if it acts up at all. any other shooters ever have this problem with pfs?

    thanks.
     
  2. TOOLMAKER 251

    TOOLMAKER 251 Active Member

    Joined:
    Jan 29, 1998
    Messages:
    3,398
    Puablo, Check the fit of the stock, sounds like your bottomed out on the ears of the stock and not the tang area first. You will stretch the tang of the reciever if this happens. You might have to bed the tang area of the pistol grip.
    George
     
Thread Status:
Not open for further replies.