1. Attention: We have put together a thread with tips and a tutorial video to help with using the new software. Please take a moment to check out the thread here: Trapshooters.com Tutorial & Help Video.
    Dismiss Notice

Problem with extractor/ejector BT-99 MAX

Discussion in 'Uncategorized Threads' started by GunDr, Sep 2, 2007.

Thread Status:
Not open for further replies.
  1. GunDr

    GunDr Well-Known Member

    Joined:
    Jan 29, 1998
    Messages:
    2,913
    Sometimes the ejector trip rod is not broken. The trip rod does need to have a little resistance to impede it's movement. I've seen many were the rod will actually float freely in the receiver. When this happens, the ejector trip rod will not stay forward to trip the ejector sear. It'll slip back into the receiver as you open the gun.

    If the rod is not broken, but moves very freely, pull it out and put a very slight bend in it. It doesn't take much.

    I believe the only BT-99's that only extracted the shells, were the BT-99-2000's.

    Doug Braker
     
  2. Piper Mac

    Piper Mac Member

    Joined:
    Jun 25, 2007
    Messages:
    84
    Doug,

    Would that explain why the gun does eject most of the time, but perhaps only 6/25 shots, it does not eject? Not enough tension?

    Simple repair or something that needs to be 'smithed' out?
     
  3. GunDr

    GunDr Well-Known Member

    Joined:
    Jan 29, 1998
    Messages:
    2,913
    Like I said above..Sometimes. You'll have to get in there and take a look. If the little round button hasn't come of the rod, then a loose rod could be the problem.

    These two areas are where I would look first. If neither of them seem to be the culprit, then maybe a small piece may have broke of the forward end, or has worn, or the ejector sear is not working properly (worn or not fitted correctly), etc, etc, etc.

    Sometimes the simplest thing can turn into a hornet's nest. And at other times, the world may be coming to an end, because a screw just loosened up.

    Doug
     
  4. Piper Mac

    Piper Mac Member

    Joined:
    Jun 25, 2007
    Messages:
    84
    Thanks for the info.........
     
  5. pjb

    pjb TS Member

    Joined:
    Jan 29, 1998
    Messages:
    8
    Had same problem with my bt99 it could be ejector rod but in my guns case the
    ejector extension had broke and did just what you are describing (part #3724)
    .Just something else you can quickly check.
     
  6. Piper Mac

    Piper Mac Member

    Joined:
    Jun 25, 2007
    Messages:
    84
    Thanks, pjb. Appreciate the info...
     
Thread Status:
Not open for further replies.