1. Attention: We have put together a thread with tips and a tutorial video to help with using the new software. Please take a moment to check out the thread here: Trapshooters.com Tutorial & Help Video.
    Dismiss Notice

MEC 9000H problem

Discussion in 'Shooting Related Threads' started by tallpaul, Feb 21, 2011.

Thread Status:
Not open for further replies.
  1. tallpaul

    tallpaul Member

    Joined:
    Oct 15, 2008
    Messages:
    249
    I have a 9000H MEC that I bought new about 8 years ago. Lately, after about loading 100 shells, the machine is making a loud CLUNK halfway through its return stroke as the machine is cycling. When there isn't a shell in the deprime/resize station, it doesn't make the noise. It doesn't make the noise until I have loaded a few boxes of shells, however. I have a suspicion it has something to do with the collet or the fork that operates the collet under the base of the machine, but I thought someone out there may have experienced this problem and have a quick diagnoses and fix. Thanks, Paul.
     
  2. Calkidd

    Calkidd Well-Known Member

    Joined:
    Jan 29, 1998
    Messages:
    2,325
    Location:
    Central Valley
    Remove the collet and the sleeve clean very well with carb cleaner or solvent. Relube and install your problem should be resolved. Make sure your plunger is dropping all the way allowing your shell to seat properly in the collet.

    Bryan
     
  3. clayman51

    clayman51 Member

    Joined:
    Jan 29, 1998
    Messages:
    437
    Tallpaul,

    You have shot or dirt built up in the collet. Remove and clean as the poster above suggest. Also check the linkage, pehaps it has busted.Some anti seize
    on the collet after cleaning.

    Dennis
     
Thread Status:
Not open for further replies.