1. Attention: We have put together a thread with tips and a tutorial video to help with using the new software. Please take a moment to check out the thread here: Trapshooters.com Tutorial & Help Video.
    Dismiss Notice

mec 9000g tech question

Discussion in 'Uncategorized Threads' started by maclellan1911, Aug 16, 2008.

Thread Status:
Not open for further replies.
  1. maclellan1911

    maclellan1911 TS Member

    Joined:
    Dec 9, 2006
    Messages:
    4,226
    Recently got a mec9000g. great deal from TS.com poster. I have a question that someone might be able to answer. I emailed seller also to see if he knows. What I have is a loader. Handle goes down fine returns fine turret turns ect ect. I was cleaning up getting ready to set for my loads. Thats when I found a 1/8" dia. X aprox 2" piece of metal which apears to be broken off on one end. It is also magnetic. It was sticking down in primer drop area to the side of the base? Also I loader 25 shells no problem then with a shell at shot/drop powder drop and derime station the handle is not going completly down? I have stopped loading until a little more info. I can not see where anything like this goes, nothing on part sheet looks like it?
     
  2. R.Kipling

    R.Kipling Well-Known Member

    Joined:
    Jul 29, 2007
    Messages:
    1,765
    Your description on the metal piece is a bit lacking, but look at the 'fingers' on your collet and see it it looks like one of them?

    Kip
     
  3. maclellan1911

    maclellan1911 TS Member

    Joined:
    Dec 9, 2006
    Messages:
    4,226
    looks like a piece of coat hanger cut from the bottom straight part. It is hard metal does not bend easyily?
     
  4. R.Kipling

    R.Kipling Well-Known Member

    Joined:
    Jul 29, 2007
    Messages:
    1,765
    If it's round, and the same diameter as a coat hanger, then I can find nothing on my 9000's that looks like it. If it's a bit larger diameter, and black then there is a guide and actuator rod on the front/center of my MEC's that controls the bar lock. Other that this, I'm out of possibilities. good luck.

    Kip
     
  5. omahasportingsupply

    omahasportingsupply TS Member

    Joined:
    Jan 7, 2007
    Messages:
    1,138
    Give us a picture Mac. I would like to buy a collet for $100 Alex. Omaha
     
  6. wizard!

    wizard! TS Member

    Joined:
    Feb 26, 2006
    Messages:
    48
    Sometime back there was a lot of problems with the old primer drop. Primers dropped and bounced out of the priming station. A possible solution was to put something magnetic to hold the primer in the drop area.
    Joe
     
  7. maclellan1911

    maclellan1911 TS Member

    Joined:
    Dec 9, 2006
    Messages:
    4,226
    I will try to get some pics sunday? It looks like a large dia. pencil lead. I to can find nothing this may go to on the loader. The loader is working with one shell at a time flawlessly. Tgry to do multible shells it locks up on wad/shot drop station. I am going to start over. check all the bolts/nuts/springs ect ect. Stran
     
  8. Big Dave

    Big Dave Member

    Joined:
    Jan 29, 1998
    Messages:
    990
    There are several parts that are rod like maybe the picture can help you identify it.

    <a href="http://s50.photobucket.com/albums/f326/dancingbear12/?action=view┬Ąt=mec.jpg" target="_blank">[​IMG]</a>
     
  9. JJJ

    JJJ TS Member

    Joined:
    Jan 29, 1998
    Messages:
    327
    CALL MEC !!!!
    JJJ
     
  10. maclellan1911

    maclellan1911 TS Member

    Joined:
    Dec 9, 2006
    Messages:
    4,226
    JJJ will call on monday, tossed it out here just incase. Im thinking it is not part of the loader.
     
  11. R.Kipling

    R.Kipling Well-Known Member

    Joined:
    Jul 29, 2007
    Messages:
    1,765
    The handle not traveling down all the way is more than likely an issue with the shot/wad seating tube. It is as justed too long.

    IME,
    Kip
     
  12. maclellan1911

    maclellan1911 TS Member

    Joined:
    Dec 9, 2006
    Messages:
    4,226
    not sure what was going on.....I started over cleaned it up. running fine now. I cleaned everything inside plastic bin. Found no shot. ?????
     
Thread Status:
Not open for further replies.