1. Attention: We have put together a thread with tips and a tutorial video to help with using the new software. Please take a moment to check out the thread here: Trapshooters.com Tutorial & Help Video.
    Dismiss Notice

help--polaris sportsman 90 quad no acceleration

Discussion in 'Off Topic Threads' started by motordoctor, Jun 9, 2011.

Thread Status:
Not open for further replies.
  1. motordoctor

    motordoctor Shoji Tabuchi in Branson

    Joined:
    Jan 29, 1998
    Messages:
    3,688
    Location:
    ohio
    friend has a problem and i'm stuck. the thing starts but engine will not speed up when you give it gas. he "rebuilt the carb" but not sure what else. seems to bog out when giving it throttle. could the auto trans be locked up and not allowing the engine to rev up??? it does roll but when you give it the gas it will not try and move. help on this one. thanks motordoc
     
  2. oz

    oz Active Member

    Joined:
    Jan 29, 1998
    Messages:
    1,817
    try prcforum.com oz
     
  3. Shooting Jack

    Shooting Jack Active Member

    Joined:
    Jul 29, 2006
    Messages:
    3,523
    Location:
    Blackshear, Georgia
    To prove that it's a fuel problem, crank it and then open throttle and spray WD40 into the carb, you can substitute starting fluid if you have some. If it rev's up then you know it's a fuel problem. I'm not sure what type of accelerator pump you have but what you have described is typical of a accelerator/fuel pump with trash or failure of some type. Jackie B.
     
  4. sliverbulletexpress

    sliverbulletexpress TS Member

    Joined:
    Jul 1, 2009
    Messages:
    2,645
    Sounds like he "rebuilt" the carb incorrectly.
     
  5. Tron

    Tron Supporting Vendor Supporting Vendor

    Joined:
    Jan 29, 1998
    Messages:
    6,673
    Sounds like a coil problem to me.
     
  6. autoparts

    autoparts Member

    Joined:
    Mar 9, 2011
    Messages:
    42
    Might check for bad camshaft will start and run but will not accelerate.
     
  7. motordoctor

    motordoctor Shoji Tabuchi in Branson

    Joined:
    Jan 29, 1998
    Messages:
    3,688
    Location:
    ohio
    updaTE. I took off the side cover and checked the belt. belt is running fine and appears that the engine will not speed up enough to make the clutch engage. I took the carb apart. blew everything out and clean. Checked the float to make sure it was working. idles perfect but when the throttle is opened will not speed up. same as before. with throttle open spray gas into carb no difference. restrict air with my finger no difference. There is some type of eletric valve on the top of the carb with two wires coming into a plug. I do NOT know what it is and where it goes. any more help is appreciated. motordoc
     
  8. Tron

    Tron Supporting Vendor Supporting Vendor

    Joined:
    Jan 29, 1998
    Messages:
    6,673
    Do you have a spark tester?? If you have a faint yellow spark, the added fuel on accel will drown it out. This is typical of a faulty coil. You can check coils resistance (should be around 10K ohm), but this doesn't always show up if the coil still gives up some kind of spark.
     
  9. kolarkim

    kolarkim Member

    Joined:
    Jan 29, 1998
    Messages:
    113
    could be bad cdi box check with known good one could be plugged exhaust unhook at head and retry I am not familiar enough with the 90 but if two stroke may not work real good but will give better idea also if four stroke could be timing chain jumped or valves too tight. hope this helps KK
     
  10. K-GUNS

    K-GUNS Member

    Joined:
    Jan 29, 1998
    Messages:
    628
    Make sure the exhaust is not blocked. Had a friend who ran over a log/tree and something hit the underside and dented the exhaust to the point where it would run but did not take the gas. Ok at idle but wouldn't go much faster than a brisk walk.
     
  11. Jimmyc

    Jimmyc TS Member

    Joined:
    Jan 29, 1998
    Messages:
    450
    Check the carb bowl and make sure the float is set correctly. Then go from there. Not saying it's not something else but id start there. Then goto spark etc.
    Jimmy
     
  12. motordoctor

    motordoctor Shoji Tabuchi in Branson

    Joined:
    Jan 29, 1998
    Messages:
    3,688
    Location:
    ohio
    ok found the problem. there is an electrical switch in the handle bar that the throttle moves. The switch is used to prevent the engine from speedingup if the throttle cable has slack or breaks or sticks--this is what the manual says. Well....the last guy had the switch disconnected. Plugged it in and almost ran over myself. For further reference I believe that you could jump the switch where the plug is and eliminate it completely as it is a normally closed switch in normal operation. Thanks for all the help. The electric solenoid on the top is some type of choke but the shop manual does not tell that it is or really how it works. The only help i got from the dealer is he let me look at the manual after i begged him. The carb is still not right and it does have a hesitation but it does run fairly well.
     
  13. Conn. Man

    Conn. Man Member

    Joined:
    Jan 29, 1998
    Messages:
    797
    Location:
    Timbucktoo
    Motordoc,not sure if it's a Mikuni carb but if it is theres a air jet to adjust on the carb body,go IN with it one quater turn,or more if needed ,that should take the flat spot out .

    Sandy Holehouse.
     
Thread Status:
Not open for further replies.
Search tags for this page
04 polaris 90 sportsman idles fine but wont go past a brisk walk
,
how to set timing on 2007 polaris sportsman 90
,
polaris 90 clutch problems
,

polaris 90 does not excelerate

,
polaris scrambler 50 only idles
,
polaris sportsman 90 running problems
,

polaris sportsman 90 wont rev up

,

scrambler 90 fuel problem