1. Attention: We have put together a thread with tips and a tutorial video to help with using the new software. Please take a moment to check out the thread here: Trapshooters.com Tutorial & Help Video.
    Dismiss Notice

Firefox censoring Cabelas.com

Discussion in 'Off Topic Threads' started by kenf, Sep 5, 2013.

  1. kenf

    kenf Active Member

    Joined:
    Jan 29, 1998
    Messages:
    1,016
    Not sure if it is just my browser at the moment, but I wanted to look at the latest arrivals in Cabelas gun library via my firefox browser and couldn't find the link in the homepage and it didn't show up in the dropdown search box. I opened my explorer browser and sure enough, both options are there. This is the first I've noticed this issue.
     
  2. skeet_man

    skeet_man Well-Known Member

    Joined:
    Jan 29, 1998
    Messages:
    10,535
    Location:
    Rochester, NY
    Are you running any ad blockers such as ad aware or adblock plus? Link shows up perfectly fine for me running firefox, under the heading of "Store Departments" near the bottom of the screen. Also shows up under "See Also" on the far right of the "Hunting" dropdown.

    Everything looks identical in IE to me.

    Using the "Search" feature, and typing in Gun Library in both browsers brings me right to the gun library as well.
     
  3. kenf

    kenf Active Member

    Joined:
    Jan 29, 1998
    Messages:
    1,016
    Not running any blockers, I may just need to update the version I'm running.
     
  4. pyrdek

    pyrdek Well-Known Member

    Joined:
    Jan 29, 1998
    Messages:
    2,297
    Where I work we had a small problem where the latest version of FF did not open a page or two from our home page when clicked. This was our on-line phone directory page. It turned out that the update improved FF security which resulted in blocking the page that was trying to be opened. The problem was NOT with FF however. It detected and prevented what was thought to be a malware attempt. When they corrected the web page to proper format, everything worked just fine.

    I don't know if that is what is going on with you but that is what happened to me. I was using FF 23.0 on an Apple.