1. Attention: We have put together a thread with tips and a tutorial video to help with using the new software. Please take a moment to check out the thread here: Trapshooters.com Tutorial & Help Video.
    Dismiss Notice

BT-99 problems

Discussion in 'Uncategorized Threads' started by hreinke, Sep 27, 2008.

Thread Status:
Not open for further replies.
  1. hreinke

    hreinke TS Member

    Joined:
    Jan 29, 1998
    Messages:
    177
    I'm having trouble with the ejector on my gun, sometimes it will pull the shell out, other times the ejector goes around the brass and I have to pull it out with a screw driver. Sent it to Williams in Flint,Mi. and they pull a larger ejector in but it is doing the same thing but not as often. Any suggestions on how to fix problem?
     
  2. tuscarora 99

    tuscarora 99 TS Member

    Joined:
    Sep 26, 2008
    Messages:
    519
    what year is this bt-88?
     
  3. maclellan1911

    maclellan1911 TS Member

    Joined:
    Dec 9, 2006
    Messages:
    4,226
    is there play in the exstractor? got to be moving to the side I would think???
     
  4. hreinke

    hreinke TS Member

    Joined:
    Jan 29, 1998
    Messages:
    177
    no play in extractor and not sure on the year
     
  5. maclellan1911

    maclellan1911 TS Member

    Joined:
    Dec 9, 2006
    Messages:
    4,226
    ok is your bt99 exstract only or eject only?
     
  6. hreinke

    hreinke TS Member

    Joined:
    Jan 29, 1998
    Messages:
    177
    sometimes they fly out other times they just pull out enough to grab it with my fingers
     
  7. hunter44

    hunter44 Well-Known Member

    Joined:
    Jan 29, 1998
    Messages:
    2,369
    What brand of shells are you using? Sounds like some of them may be sticking in the chamber with the ejector having some play in it & slipping over the shell rim?
     
  8. grunt

    grunt TS Supporters TS Supporters

    Joined:
    Jan 29, 1998
    Messages:
    5,920
    Location:
    Thousand Oaks Ca
    A club member had this type of problem. He remover the stock and found that the ejector rod had lost the button that is silver soldered to the rod. It allows the rod to cock from time to time and this is when the shell wouldnt eject. The button was in the reciever. You can get this part from Brownells it needs to be fitted..
     
  9. hreinke

    hreinke TS Member

    Joined:
    Jan 29, 1998
    Messages:
    177
    OK Thanks for the help guys I have been useing wally world federal shells, but it did it with Win.AA too.
     
  10. GunDr

    GunDr Well-Known Member

    Joined:
    Jan 29, 1998
    Messages:
    2,913
    It could also be possible that the chamber has become oversize, allowing the shell to tip, in turn, allowing the extractor to slip by.

    Doug
     
  11. hreinke

    hreinke TS Member

    Joined:
    Jan 29, 1998
    Messages:
    177
    The bore could be the problem, it was pretty rusty in there when I first got it. Might have honed it out to much.
     
  12. GunDr

    GunDr Well-Known Member

    Joined:
    Jan 29, 1998
    Messages:
    2,913
    The chamber shouldn't measure over .815" just below the rim cut. If it's over .820", it definitely could be causing the problem.

    Doug
     
Thread Status:
Not open for further replies.